您的位置:首页 > 其它

POJ 2349 Arctic Network 【最小生成树变形】

2016-07-29 17:38 369 查看
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost
will have a radio transceiver and some outposts will in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow,
giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750


Sample Output

212.13


题目解法:在最小生成树添加的边里找个最小的

AC代码:#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAXN 555
#define inf 1LL<<60

struct Node
{
int x,y;
} node[MAXN];
double map[MAXN][MAXN];
double lowcost[MAXN];
double dist[MAXN];
bool mark[MAXN];
int n,m;

double Cal(int i,int j)
{
double d1=1.0*(node[i].x-node[j].x)*(node[i].x-node[j].x);
double d2=1.0*(node[i].y-node[j].y)*(node[i].y-node[j].y);
return sqrt(d1+d2);
}

int cmp(const double &p,const double &q)
{
return p>q;
}

double Prim()
{
int cnt=0;
memset(mark,false,sizeof(mark));
for(int i=1; i<=m; i++)
{
lowcost[i]=map[1][i];
}
lowcost[1]=0;
mark[1]=true;
for(int i=1; i<m; i++)
{
double MIN=inf;
int v ;
for(int j=1; j<=m; j++)
{
if(!mark[j]&&lowcost[j]<MIN)
{
MIN=lowcost[j],v=j;
}
}
if(MIN==inf)break;
mark[v]=true;
dist[cnt++]=lowcost[v];
for(int k=1; k<=m; k++)
{
if(!mark[k]&&map[v][k]<lowcost[k])
{
lowcost[k]=map[v][k];
}
}
}
sort(dist,dist+cnt,cmp);

return dist[n-1];
}

int main()
{
int t,a,b;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1; i<=m; i++)
for(int j=1; j<=m; j++)
map[i][j]=map[j][i]=(i==j?0:inf);
for(int i = 1 ; i<=m; i++)scanf("%d%d",&node[i].x,&node[i].y);
for(int i=1; i<=m; i++)
{
for(int j=1; j<=m; j++)
{
map[i][j]=map[j][i]=Cal(i,j);
}
}
printf("%.2lf\n",Prim());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: