您的位置:首页 > 其它

poj 2456 Aggressive cows 二分+贪心

2016-07-29 16:25 423 查看
Aggressive cows

Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9

Sample Output
3


题意:有c只牛,n个隔间,牛会打架,所以要牛之前的最小距离最大

思路:先把距离排序,两只牛最小距离是1,最大是(a[N - 1] - a[0]) / (c - 1),利用二分找中间位置mid的隔间距可能的取值,贪心是否能放下c只羊

//二分加贪心
#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional>
using namespace std;

int N, C;
int a[100005];

int fun(int x) { //贪心
int k = 0;   //记录能放入的羊的只数
int m = a[0]; //初始化
for (int i = 1; i < N; i++) {
if (a[i] >= m + x) { //距离满足条件
k++;
m = a[i];
}
}
if (k >= C - 1) return 1;
else return 0;
}

int main()
{
while (cin >> N >> C) {
for (int i = 0; i < N; i++) {
cin >> a[i];
}
sort(a, a + N);  //从小到大排序
int max = (a[N - 1] - a[0]) / (C - 1);  //最小值的上限 C个羊需要C-1个间隔
int min = 1;  //下限为1
while (max >= min) {  //二分
int mid = (max + min) / 2;
if (fun(mid) == 1) //贪心判断间隔为mid时,能否放下C只羊
min = mid + 1;
else
max = mid - 1;
}
cout << min - 1 << endl; //循环结束之前,min = mid+1,现在需要把1减去
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj 二分 贪心