您的位置:首页 > 其它

Codeforces Round #249 (Div. 2)C Devu and Partitioning of the Array

2016-07-28 23:26 609 查看

题目链接: 传送门

Devu and Partitioning of the Array

time limit per test:1 second     memory limit per test:256 megabytes

Description

Devu being a small kid, likes to play a lot, but he only likes to play with arrays. While playing he came up with an interesting question which he could not solve, can you please solve it for him?
Given an array consisting of distinct integers. Is it possible to partition the whole array into k disjoint non-empty parts such that p of the parts have even sum (each of them must have even sum) and remaining k - p have odd sum? (note that parts need not to be continuous).
If it is possible to partition the array, also give any possible way of valid partitioning.

Input

The first line will contain three space separated integers n, k, p (1 ≤ k ≤ n ≤ 10^5; 0 ≤ p ≤ k). The next line will contain n space-separated distinct integers representing the content of array a: a1, a2, ..., an (1 ≤ ai ≤ 10^9).

Output

In the first line print "YES" (without the quotes) if it is possible to partition the array in the required way. Otherwise print "NO" (without the quotes).
If the required partition exists, print k lines after the first line. The ith of them should contain the content of the ith part. Print the content of the part in the line in the following way: firstly print the number of elements of the part, then print all the elements of the part in arbitrary order. There must be exactly p parts with even sum, each of the remaining k - p parts must have odd sum.
As there can be multiple partitions, you are allowed to print any valid partition.

Sample Input

5 5 3
2 6 10 5 9

5 5 3
7 14 2 9 5

5 3 1
1 2 3 7 5

Sample Output

YES
1 9
1 5
1 10
1 6
1 2

NO

YES
3 5 1 3
1 7
1 2

解题思路:

题目大意:给n个数字,问能够将这n个数分成p堆,每堆和为偶数,k-p堆,每堆和为奇数
简单分堆,稍微注意一下细节处理。

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
int n,k,p;
while (~scanf("%d%d%d",&n,&k,&p))
{
int tmp;
vector<int>itv1,itv2;
for (int i = 0; i < n; i++)
{
scanf("%d",&tmp);
if (tmp & 1)
{
itv1.push_back(tmp);
}
else
{
itv2.push_back(tmp);
}
}
int len1 = itv1.size();
int len2 = itv2.size();
if (len1 < (k - p) || ((len1 - (k - p))&1) || ((len1 - (k - p))/2 + len2 < p))
{
printf("NO\n");
}
else
{
int x = k - p;
printf("YES\n");
for (int i = 0;i < x - 1;i++)
{
printf("1 %d\n",itv1.back());
itv1.pop_back();
}
for (int i = 0;i < p - 1;i++)
{
if (!itv2.empty())
{
printf("1 %d\n",itv2.back());
itv2.pop_back();
}
else
{
printf("2");
for (int j = 0;j < 2;j++)
{
printf(" %d",itv1.back());
itv1.pop_back();
}
printf("\n");
}
}
if (x && p)
{
printf("1 %d\n",itv1.back());
itv1.pop_back();
}
printf("%d",itv1.size()+itv2.size());
while (!itv1.empty())
{
printf(" %d",itv1.back());
itv1.pop_back();
}
while (!itv2.empty())
{
printf(" %d",itv2.back());
itv2.pop_back();
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: