您的位置:首页 > 产品设计 > UI/UE

poj 2299 Ultra-QuickSort

2016-07-27 22:18 459 查看
Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 54529 Accepted: 20042
Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is
sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence
element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 510000;
long long sum;
int a
, anew
;
void msort(int l,int r);
void merg(int l,int mid,int r);

int main()
{
    int n;
    while(scanf("%d", &n),n!=0)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d", &a[i]);
        }
        sum=0;
        msort(1,n);
        printf("%lld\n",sum);
    }
    return 0;
}

void msort(int l,int r)
{
    if(l==r)
    {
        anew[l]=a[l];
        return ;
    }
    else
    {
        int mid=(l+r)/2;
        msort(l,mid);
        msort(mid+1,r);
        merg(l,mid,r);
        return ;
    }
}

void merg(int l,int mid,int r)
{
    int i, j, k=l;
    for(i=l,j=mid+1;i<=mid&&j<=r;k++)
    {
        if(a[i]<a[j])
        {
            anew[k]=a[i++];
        }
        else
        {
            sum+=j-k;
            anew[k]=a[j++];
        }
    }
    while(i<=mid)
    {
        anew[k++]=a[i++];
    }
    while(j<=r)
    {
        anew[k++]=a[j++];
    }
    for( i=l;i<=r;i++)
    {
        a[i]=anew[i];
    }
    return ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: