您的位置:首页 > 编程语言 > Go语言

POJ2007 Scrambled Polygon

2016-07-27 21:09 726 查看
POJ2007  Scrambled Polygon

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 8198 Accepted: 3891

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly
once, one comes back to the starting vertex. 
A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have
any "dents".) 



The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with
(0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 





Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999.
The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip
taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input

0 0

70 -50

60 30

-30 -50

80 20

50 -60

90 -20

-30 -40

-10 -60

90 10

Sample Output

(0,0)

(-30,-40)

(-30,-50)

(-10,-60)

(50,-60)

(70,-50)

(90,-20)

(90,10)

(80,20)

(60,30)

解题思路:叉积排序

叉积的介绍如下:



在二维情况中,



a x b 为有向面积,可正可负。当a可逆时针旋转小于180°到达b,则结果为正,否则结果为负。

我们观察,可以发现如果一个点所对应的向量a通过逆时针方向旋转小于180°的方向得到向量b(我们称作a > b),我们就先输出a否则先输出b,也就是说先输出大的向量。a > b对应于 叉积为正,于是我们可以通过叉积来判断a和b的大小,进而进行排序。

程序代码如下:

#include "iostream"

#include "algorithm"

using namespace std;

struct vertices{
int x;
int y;

} v[55];

bool cmp(struct vertices m, struct vertices n){
int z = m.x*n.y - n.x*m.y;
if(z > 0) return z;
return 0;

}

int main(){

int n=0;
while( cin >> v
.x >> v
.y) n++;

sort(v+1,v+n,cmp);

for(int i=0; i < n;i++)
cout<<"("<<v[i].x<<","<<v[i].y<<")"<<endl;

return 0;

}

提交结果如下:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: