您的位置:首页 > 其它

HDU Problem 2199 Can you solve this equation? 【二分】

2016-07-27 21:06 477 查看
 

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16602    Accepted Submission(s): 7371


[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

[align=left]Sample Input[/align]

2
100
-4

 

[align=left]Sample Output[/align]

1.6152
No solution!

 
题中说解在0~100之间,所以当输入的值小于x=0时的值大于x=100时候的值是不存在的,其他情况都有解,所以,对于其他情况,直接进行二分。

#include <cstdio>
#include <cmath>
using namespace std;

const double sp = 1e-5;
double ans(double x) {
return 8*pow(x, 4.0) + 7*pow(x, 3.0) + 2*pow(x, 2.0) + 3*x + 6;
}

double lower_bound(double x) {
double l = 0, r = 100;
double mid = (l + r)/2;
while (abs(ans(mid) - x) > sp) {
mid = (l + r)/2;
if (ans(mid) > x) {
r = mid;
}
else {
l = mid;
}
}
return mid;
}
int main() {
int t;
double n;
scanf("%d", &t);
while (t--) {
scanf("%lf", &n);
if (n < 6 || n > ans(100.0))
printf("No solution!\n");
else printf("%.4lf\n", lower_bound(n));
}
return 0;
}


 

[align=left] [/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 杭电