您的位置:首页 > 其它

Can you solve this equation?(二分)

2016-07-26 10:58 393 查看
[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

[align=left]Sample Input[/align]

2
100
-4

 

[align=left]Sample Output[/align]

1.6152
No solution!

 
0-100之间是递增的,可以用二分
#include<cstdio>
#include<cmath>
#define eqs 1e-12
double hany(double y)
{
return 8.0*pow(y,4.0)+7.0*pow(y,3)+2.0*pow(y,2.0)+3*pow(y,1.0)+6.0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
double y;
scanf("%lf",&y);
if(y<hany(0)||y>hany(100))
printf("No solution!\n");
else
{
double l=0.0,r=100.0,mid;
int size=50;
while(size--)
{
mid=(l+r)/2.0;
if(hany(mid)>y)
r=mid+eqs;
else l=mid+eqs;
}
printf("%.4lf\n",l);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: