您的位置:首页 > 其它

1082. Read Number in Chinese (25)

2016-07-25 11:32 369 查看
Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero
("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789

Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:
100800

Sample Output 2:
yi Shi Wan ling ba Bai


用读中文的方法读出给出的数字,要考虑的情况比较多。

首先将数字分成四位为一组(开头的可以不满4位),因为每四位的读法是一样的。有如下的情况:

1.0算是一种特殊的情况;

2.1234这种是最容易的情况,直接每一位都读出来,即yi Qian er Bai san Shi si;

3.1023这种带有0的,零的那一位只读出零就行了,即yi Qian ling er Shi san;

4.1002这种两个0连着的,只读出一个零,即yi Qian ling er;

5.0012这种是0开头的,零的地方只读出零且只读出一个,即ling yi Shi er;

6.1200这种是0结尾的,不用读出零,即yi Qian er Bai;

7.其他情况是还不满四位的,也是按照上面的规律。

这样得到每四位的读法,然后如果有9位数,则用“Yi“和“Wan“连接;如果是5到8位数,则用“Wan”来连接;如果小于等于4位,则按照四位数的读法直接读出。注意最后不能留有空格。

代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;

string read1[10]={"ling ","yi ","er ","san ","si ","wu ","liu ","qi ","ba ","jiu "};
string read2[5]={"","","Shi ","Bai ","Qian "};
string read3[4]={"","","Wan ","Yi "};

string read4(string s)
{
int i=0,j=0,n=s.size();
string ret="";
while(true)
{
j=i;
while(s[i]=='0'&&i<n) i++;
if(i==n) break;
if(i!=j) ret+="ling ";
else
{
ret+=read1[s[i]-'0']+read2[n-i];
i++;
}
if(i==n) break;
}
return ret;
}

int main()
{
string num;
cin>>num;
if(num=="0")
{
cout<<"ling"<<endl;
return 0;
}
string res="";
if(num[0]=='-')
{
res+="Fu ";
num=num.substr(1);
}
int n=num.size(),m,k=(n%4==0)?4:n%4;
if(n==9) m=3;
else if(n>=5) m=2;
else m=1;
for(int i=m;i>0;i--)
{
if(i<m) k=4;
res+=read4(num.substr(0,k));
num=num.substr(k);
res+=read3[i];
}
res=res.substr(0,res.size()-1);
cout<<res<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  math string