您的位置:首页 > 其它

PAT(B) - 1028. 人口普查(20)

2016-07-25 10:48 351 查看


1028. 人口普查(20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:
3 Tom John


题目简单易懂,没什么特别需要注意的地方,注意判断好生日范围就行了。建议用C语言中的格式化输入。

#include <cstdio>
#include <cstring>
#include <vector>
#include <cstdlib>

using namespace std;

typedef struct {
char name[6];
int year;
int month;
int day;
} Person;

int cmp( void const *p1,void const *p2 ) {
if(((Person *)(p1))->year>((Person *)(p2))->year) return 1;
else if(((Person *)(p1))->year<((Person *)(p2))->year) return 0;
else {
if(((Person *)(p1))->month>((Person *)(p2))->month) return 1;
else if(((Person *)(p1))->month==((Person *)(p2))->month&&((Person *)(p1))->day>((Person *)(p2))->day) return 1;
else return 0;
}
}

bool isValid( Person p ) {
//判断生日上限
if( p.year > 2014 ) return false;
if( p.year == 2014 && p.month > 9 ) return false;
if( p.year == 2014 && p.month == 9 && p.day > 6 ) return false;

//判断生日下限
if( p.year < 1814 ) return false;
if( p.year == 1814 && p.month < 9 ) return false;
if( p.year == 1814 && p.month == 9 && p.day < 6 ) return false;

return true;
}

int main() {
//freopen( "123.txt", "r", stdin );
int n;
scanf( "%d", &n );

Person p;
vector<Person> vec;

int count = 0; //统计有效生日的人数
bool flag = true;
for( int i = 0; i < n; i++ ) {
scanf( "%s%d/%d/%d", p.name, &p.year, &p.month, &p.day );
flag = isValid( p );
if( flag ) {
vec.push_back( p );
count++;
}
}

qsort( &vec[0], count, sizeof( Person ), cmp );

if( count > 0 ) {
printf( "%d %s %s", count, vec[0].name, vec[count - 1].name );
}
else {
printf( "0" );
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: