您的位置:首页 > 其它

poj 1328 Radar Installation

2016-07-25 09:24 337 查看
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

思路:算出 每个小岛能被覆盖的雷达的圆心,即以小岛为圆心 R为半径 作圆,该圆与X轴的交点:
左交点为x-sqrt(R*R-y*y); 右交点为x+sqrt(R*R-y*y);
按照 左交点 排序,如果i点的左交点在 当前雷达的右边 则需安装一个新雷达,更新雷达
否则 如果 i点的右交点也在当前雷达的左边 则把当前雷达的圆心更新为该点的右交点;




#include<stdio.h>
#include<iostream>
#include<cmath>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
double l,r;
}  p[1000];
bool cmp(node a,node b)
{
return a.l<b.l;
}
int main()
{
int n,d,i,x,y,sw,re,count = 1;
double pre;
while(1)
{
scanf("%d %d",&n,&d);
if(n == 0 && d==0) break;
sw = 1;
for(i=0; i<n; i++)
{
scanf("%d %d",&x,&y);
if(d>=y&&sw==1)
{
p[i].l = x-sqrt((double)d*d - (double)y*y);
p[i].r = x+sqrt((double)d*d - (double)y*y);
}
else
{
sw = 0;
}
}
if(sw == 0)
{
printf("Case %d: -1\n",count++);
continue;
}
sort(p,p+n,cmp);
re = 1;
pre = p[0].r;
for(i=1; i<n; i++)
{
if(p[i].l>pre)
{
re++;
pre = p[i].r;
}
else
{
if(p[i].r<pre)
{
pre = p[i].r;
}
}
}
printf("Case %d: %d\n",count++,re);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: