您的位置:首页 > Web前端

POJ2492 A Bug's Life 并查集

2016-07-24 18:37 218 查看
Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 
Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
Source

TUD Programming Contest 2005, Darmstadt, Germany

与食物链一题很相似。

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
#define maxn 2000
int n,m,flag;
int parent[maxn+10];
int re[maxn+10];
int getparent(int a)
{
if(parent[a]!=a){
int temp=getparent(parent[a]);
re[a]=(re[parent[a]]+re[a])&1;
parent[a]=temp;
}
return parent[a];
}
void Merge(int p,int q)
{
int a=getparent(p);
int b=getparent(q);
if(a==b){
if(re[p]==re[q]){
flag=1;
}
return;
}
parent[b]=a;
re[b]=(re[q]+re[p]+1)&1;
}
int main()
{
int t,ca=1;
scanf("%d",&t);
while(t--){
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<=n;i++){
parent[i]=i;
re[i]=0;
}
flag=0;
int p,q;
while(m--){
scanf("%d%d",&p,&q);
if(flag){
continue;
}
Merge(p,q);
}
printf("Scenario #%d:\n",ca++);
if(flag){
printf("Suspicious bugs found!\n");
}else{
printf("No suspicious bugs found!\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: