您的位置:首页 > 其它

HDU 1358 Period (kmp求循环节)

2016-07-24 18:17 423 查看
题目链接:点击打开链接

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6523    Accepted Submission(s): 3144


[align=left]Problem Description[/align]
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

[align=left]Input[/align]
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.

 

[align=left]Output[/align]
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.

 

[align=left]Sample Input[/align]

3
aaa
12
aabaabaabaab
0

 

[align=left]Sample Output[/align]

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目大意:给你一串字符串,问循环节的位置,以及循环了几次。直接用kmp求循环节

#include <stdio.h>
#include <string.h>
int next[1000010];
char c[1000010];
void getnext()
{
memset(next,0,sizeof(int)*1000010);
int len=strlen(c);
next[0]=-1;
int j=0;
int k=-1;
while(c[j])
{
if(k == -1 || c[j] == c[k])
{
j++;
k++;
next[j] = k;
}
else
{
k = next[k];
}
}
}
int main()
{
int n;
int cas=1;
while(~scanf("%d",&n))
{
if(n == 0) break;
scanf("%s",c);
printf("Test case #%d\n",cas++);
getnext();
for(int i=2;c[i-1];i++)
{
int t = i - next[i];
if(i % t == 0 && i/t>1)
printf("%d %d\n",i,i/t);
}
putchar(10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息