您的位置:首页 > 编程语言 > C语言/C++

1100. Mars Numbers (20)

2016-07-24 16:02 429 查看

1100. Mars Numbers (20)

 

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People on Mars count their numbers with base 13:

Zero on Earth is called "tret" on Mars.

The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.

For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth
and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam

Sample Output:
hel mar
may
115
13


注意点:

1、13的整数倍的输出情况

2、注意tret是四个字母,读取时要注意,输出时应为0

 

 

#include <stdio.h>
#include <string.h>

int main()
{
char a[13][5]={"tret","jan", "feb", "mar", "apr", "may","jun", "jly", "aug", "sep", "oct", "nov", "dec"};
char b[12][4] ={"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
char d[4];
int N,i,number=0,j;
char c;
scanf("%d",&N);
getchar();
for(i=0;i<N;i++)
{
number = 0;
c = getchar();
if(c <= '9' && c >='0')
{
number = c-'0';
c = getchar();
if(c !='\n')
{
number = number*10+c-'0';
c = getchar();
if(c !='\n')
{
number = number*10+c-'0';
if(number %13!=0)
{
printf("%s %s\n",b[number/13-1],a[number%13]);
}
else
{
printf("%s\n",b[number/13-1]);
}
c = getchar();
}
else
{
if(number>13 && number%13!=0)
{
printf("%s %s\n",b[number/13-1],a[number%13]);
}
else
{
if(number %13!=0)
{
printf("%s\n",a[number]);
}
else
{
printf("%s\n",b[number/13-1]);
}
}
}
}
else
{
printf("%s\n",a[number]);
}
}
else
{
d[0] = c;
scanf("%s",&d[1]);
c =getchar();
if(c !='\n')
{
for(j=0;j<12;j++)
{
if(strcmp(d,b[j]) == 0)
{
number += (j+1)*13;
break;
}
}
scanf("%s",d);
getchar();
for(j=0;j<13;j++)
{
if(strcmp(d,a[j]) == 0)
{
number += j;
printf("%d\n",number);
break;
}
}
}
else
{
for(j=0;j<13;j++)
{
if(strcmp(d,a[j])==0)
{
printf("%d\n",j);
break;
}
}
for(j=0;j<12;j++)
{
if(strcmp(d,b[j])==0)
{
printf("%d\n",(j+1)*13);
break;
}
}
}

}
}
return 0;
}


 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息