您的位置:首页 > 编程语言 > C语言/C++

1002. A+B for Polynomials (25)

2016-08-29 14:07 316 查看

1002. A+B for Polynomials (25)

 

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK,
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


 

因为是PAT的代码所以干脆最后没有free了,需要注意。

#include <stdio.h>
#include <stdlib.h>

typedef struct node
{
int exp;
double coef;
struct node *next;
}NODE;

NODE* GetP(void)
{
int k,i,expp;
double coeff;
NODE *head;
NODE *p,*t;
head = (NODE*)malloc(sizeof(NODE));
head ->next = NULL;
p = head;
scanf("%d",&k);
for(i=0;i<k;i++)
{
scanf("%d %lf",&expp,&coeff);
t = (NODE*)malloc(sizeof(NODE));
t->exp = expp;
t->coef = coeff;
t->next = NULL;
p->next = t;
p = t;
}
return head;
}

NODE* AddP(NODE *PA,NODE *PB)
{
NODE *head;
NODE *p,*t;
head = (NODE*)malloc(sizeof(NODE));
head->next = NULL;
p = head;
PA = PA->next;
PB = PB->next;
while(PA!=NULL && PB!= NULL)
{
if(PA->exp == PB->exp)
{
if(PA->coef + PB->coef!=0)
{
t = (NODE*)malloc(sizeof(NODE));
t->exp = PA->exp;
t->coef = PA->coef + PB->coef;
t->next = NULL;
p->next = t;
p = t;
}
PA = PA->next;
PB = PB->next;
}
else if(PA->exp > PB->exp)
{
t = (NODE*)malloc(sizeof(NODE));
t->exp = PA->exp;
t->coef = PA->coef;
t->next = NULL;
PA = PA->next;
p->next = t;
p = t;
}
else
{
t = (NODE*)malloc(sizeof(NODE));
t->exp = PB->exp;
t->coef = PB->coef;
t->next = NULL;
PB = PB->next;
p->next = t;
p = t;
}

}
while(PA != NULL)
{
t = (NODE*)mal
4000
loc(sizeof(NODE));
t->exp = PA->exp;
t->coef = PA->coef;
t->next = NULL;
PA = PA->next;
p->next = t;
p = t;
}
while(PB != NULL)
{
t = (NODE*)malloc(sizeof(NODE));
t->exp = PB->exp;
t->coef = PB->coef;
t->next = NULL;
PB = PB->next;
p->next = t;
p = t;
}
return head;
}

int main()
{
NODE *PA,*PB,*PC,*p;
int k;
PA = GetP();
PB = GetP();
PC = AddP(PA,PB);
if(PC->next == NULL)
{
printf("0");
return 0;
}
PC = PC->next;
for(k=0,p=PC;p!=NULL;k++,p=p->next);
printf("%d ",k);
while(PC->next!=NULL)
{
printf("%d %.1lf ",PC->exp,PC->coef);
PC = PC->next;
}
printf("%d %.1lf",PC->exp,PC->coef);
return 0;
}


 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息