您的位置:首页 > 其它

poj 1611 并查集

2016-07-24 14:57 344 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 32831 Accepted: 15917
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


题意:0  号学生有病,会传染,然后根据相应的组,计算得病的个数

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

const int maxx=30005;
int father[maxx];
int sum[maxx];

int find_it(int x)
{
int tempx=x,t;
while(tempx!=father[tempx])
tempx=father[tempx];
while(x!=father[x])
{
t=father[x];
father[x]=tempx;
x=t;
}
return tempx;
}

void unite(int num1,int num2)
{
int tx=find_it(num1);
int ty=find_it(num2);
if(tx!=ty){
father[tx]=ty;
sum[ty]+=sum[tx];
}
}

int main()
{
//freopen("in.txt","r",stdin);
int n,m;
while(scanf("%d%d",&n,&m)&&(n+m))
{
for(int i=0;i<=n;i++){
father[i]=i;
sum[i]=1;
}
for(int i=0;i<m;i++){
int k,a,b;
scanf("%d",&k);
scanf("%d",&a);
for(int j=0;j<k-1;j++){
scanf("%d",&b);
unite(a,b);
}
}

printf("%d\n",sum[find_it(0)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: