您的位置:首页 > 其它

poj1979 Red and Black

2016-07-24 08:24 441 查看
A - Red and Black

Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%lld & %llu

Submit

Status

Practice

POJ 1979

Appoint description:

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile

‘#’ - a red tile

‘@’ - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

….#.

…..#

……

……

……

……

……

@…

.#..#.

11 9

.#………

.#.#######.

.#.#…..#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#…….#.

.#########.

………..

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

.

…@…

.

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

题意:求能够遍历多少‘.’格

思路:直接bfs即可

注意 此处可能只有一个开始的‘@’格子,而并没有‘.’格子

#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;

int n,m;
char mp[30][30];
struct data
{
int x,y;
}st,en;
queue<data> que;
int all=0;
bool vis[30][30];
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
bool ok(int x,int y)
{
if(x<0||x>=n||y<0||y>=m)
return 0;
if(vis[x][y]||mp[x][y]=='#')
return 0;
return 1;

}
void bfs()
{
memset(vis,0,sizeof vis);
while(!que.empty())
que.pop();

que.push(st);
all=1;
vis[st.x][st.y]=1;
while(!que.empty())
{
data  now=que.front();
que.pop();

for(int i=0;i<4;i++)
{
data ne=now;
ne.x+=dx[i];
ne.y+=dy[i];
if(!ok(ne.x,ne.y))
{
continue;
}
vis[ne.x][ne.y]=1;
que.push(ne);
all++;

}
}

}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF&&n&&m)
{
all=0;
for(int i=0;i<n;i++)
{
scanf("%s",mp[i]);
}
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{

if(mp[i][j]=='@')
{
st.x=i;
st.y=j;
}
}
}

bfs();

printf("%d\n",all);
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: