您的位置:首页 > 其它

Ekka Dokka

2016-07-23 20:36 393 查看
Description

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the
cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive
integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then
print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

把一个数分成一个偶数和一个奇数  要求偶数尽可能小

#include<cstdio>
int main()
{
int t;
int cut=0;
scanf("%d",&t);
while(t--)
{
cut++;
long long n;
scanf("%lld",&n);
printf("Case %d: ",cut);
if(n%2==1)
{
printf("Impossible\n");
}
else
{
for(long long i=2;i<=n;i+=2)
{
if(n%i==0&&(n/i)%2==1)
{
printf("%lld %lld\n",n/i,i);
break;
}

}
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: