您的位置:首页 > 理论基础 > 数据结构算法

POJ 2406 Power Strings 数据结构+KMP

2016-07-23 15:31 417 查看
 Power Strings

Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%lld
& %llu
SubmitStatus

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3


Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

解题思路:

一看就知道考的是kmp的失配函数/next数组的含义

看最后一个字符的f[i] 如果n%(n-f
)!=0那就是不循环的

否则循环节就是n/(n-f
)

面对这种题,只要自己对失配函数和next理解到一定程度,基本不用太多思考

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn = 1000005 ;
char str[maxn] ;
int f[maxn] ;
void getfail(){
f[0] = 0 ;
f[1] = 0 ;
int n = strlen(str);
for(int i=1;i<n;i++){
int j = f[i] ;
while(j&&str[i]!=str[j])j = f[j] ;
f[i+1] = (str[i]==str[j]?j+1:0) ;
}
return ;
}
int main(){
while(~scanf("%s",str)){
if(str[0]=='.')break ;
getfail();

//        for(int i=0;i<=strlen(str);i++){
//            printf("%d ",f[i]);
//        }printf("\n");

int n = strlen(str) ;
int t = n-f
;
if(n%t==0){
printf("%d\n",n/t);
}else{
printf("1\n");
}
}
return 0;

}


a564
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: