您的位置:首页 > 其它

【HDU】1796 - How many integers can you find(容斥原理,GCD)

2016-07-23 11:09 381 查看
点击打开题目


How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6760    Accepted Submission(s): 1961


Problem Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10},
all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

 

Output

  For each case, output the number.

 

Sample Input

12 2
2 3

 

Sample Output

7

 

Author

wangye

 

Source

2008
“Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

 

有几点需要注意:

①m里的值可能是0

②m的值可能不互质,这时候取数的时候不能直接相乘,要求LCM( )

③m里的数可能大于等于n

④n要减一

代码如下:

#include <cstdio>
#include <cstring>
int GCD(int a,int b)
{
if (a % b == 0)
return b;
return GCD(b,a%b);
}
int LCM(int a,int b)
{
return a/GCD(a,b)*b;
}
int main()
{
int n;
int m;
int num[30];
while (~scanf ("%d %d",&n,&m))
{
for (int i = 0 ; i < m ; i++)
{
scanf ("%d",&num[i]);
if (num[i] < 1 || num[i] >= n) //大于等于n的也要删掉
{
m--;
i--;
}
}
//用容斥原理直接求
n--;
int ans = 0;
for (int i = 1 ; i < (1 << m) ; i++)
{
int v = 1;
int k = 0; //计数
for (int j = 0 ; j < m ; j++)
{
if ((1 << j) & i)
{
v = LCM(v,num[j]);
k++;
}
}
if (k & 1)
ans += n / v;
else
ans -= n / v;
}
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: