您的位置:首页 > 其它

poj Radar Installation 【贪心 区间】

2016-07-23 10:23 344 查看
Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 75358 Accepted: 16865
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 


 

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

Source

Beijing 2002

嗯,每个岛屿的雷达有个区间范围,区间覆盖,[l , r], 右端点从小到大排序,并更新右端点

坐标是浮点型

rightn=-1000000000

#include<cstdio>
#include<cmath>
#include<algorithm>
#define INF 1000000000
using namespace std;

struct Node{
double left,right;
}node[1010];
bool cmp(Node x,Node y)
{
return x.right<y.right;
}
int main()
{
int n,k=0;
double d,x,y;
while(scanf("%d%lf",&n,&d)&&(n||d))
{
int flag=1;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&x,&y);
if(!flag)	continue;
if(y>d)
{
flag=0;
continue;
}
node[i].left=x-sqrt(d*d-y*y);
node[i].right=x+sqrt(d*d-y*y);
}
printf("Case %d: ",++k);		//先输出Case
if(!flag)
{
printf("-1\n");
continue;
}
sort(node,node+n,cmp);
double rightn=-INF;			//横坐标是浮点型数
int ans=0;
for(int i=0;i<n;i++)
{
if(rightn<node[i].left)
{
ans++;
rightn=node[i].right;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: