您的位置:首页 > 产品设计 > UI/UE

UVA 11538 Chess Queen

2016-07-22 22:02 330 查看
Question:

You probably know how the game of chess is played and how chess queen operates. Two chess queens

are in attacking position when they are on same row, column or diagonal of a chess board. Suppose

two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be

in attacking positions in 12 ways, these are shown in the picture below:

Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways

Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking

position in that.

Input

Input file can contain up to 5000 lines of inputs. Each line contains two non-negative integers which

denote the value of M and N (0 < M, N ≤ 106

) respectively.

Input is terminated by a line containing two zeroes. These two zeroes need not be processed.

Output

For each line of input produce one line of output. This line contains an integer which denotes in how

many ways two queens can be in attacking position in an (M × N) board, where the values of M and

N came from the input. All output values will fit in 64-bit signed integer.

Sample Input

2 2

100 223

2300 1000

0 0

Sample Output

12

10907100

11514134000

题意大意:两个皇后放在一个n*m的矩形方阵中,两个皇后在同一水平,同一竖直,同一斜线上均会互相攻击,让你输出共有多少中方案使两个皇后互相攻击。

思路:水平的和竖直的情况非常容易考虑,但斜线就不容易想到了。我们可以先算非最长的对角线的请况,sum+=4*i*(i-1);1<=i

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const int Max=1000005;
long long  a[Max];
int main()
{
long long  n,m;
while(1)
{
long long sum=0;
scanf("%lld%lld",&n,&m);
if(n==0&&m==0)
break;
sum+=(n*(n-1)*m+m*(m-1)*n);     //这里算的是水平和竖直的情况
for(long long i=1;i<min(n,m);i++)
sum+=4*i*(i-1);        //这里算的是非最长对角线的请况
long long  t=abs(n-m),h=min(n,m);  //这里算的最长对角线的情况(当n!=m时,最长对角线不只有一条)
sum+=2*(t+1)*h*(h-1);
printf("%lld\n",sum);
}
return 0;
}


体会:把问题细化,可能就会变得简单。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 ACM