您的位置:首页 > 其它

poj 2349(Prime + Kruskal 最小生成树)

2016-07-22 16:52 204 查看
Arctic Network

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16591 Accepted: 5284
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will
in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750

Sample Output
212.13

Source

题意:

国防部(DND)要用无线网络连接北部几个哨所。两种不同的通信技术被用于建立网络:每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道。
任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置。同时,当两个哨所之间的距离不超过D时可以通过无线电通讯,D取决于对收发器的功率。功率越大,D也越大,但成本更高。出于采购和维修的方便,所有哨所的收发器必须是相同的;那就是说,D值对每一个哨所相同。
 
你的任务是确定收发器的D的最小值。每对哨所间至少要有一条通信线路(直接或间接)。

Input

输入的第一行是测试数据的数量N。
每组测试数据的第一行包含卫星的数量S(1 < = S < = 100)和哨所的数量P(S < P < = 500)。接下来的P行,给出以公里为单位的每个哨所的坐标(x,y)( 坐标为0到10000之间的整数)。

Output

对于每组测试数据,输出一行,输出收发器的D的最小值。精确到小数点后两位。

分析:
有S颗卫星和P个哨所,有卫星的两个哨所之间可以任意通信;否则,一个哨所只能和距离它小于等于D的哨所通信。给出卫星的数量和P个哨所的坐标,求D的最小值。这是一个最小生成树问题。P个哨所最多用P-1条边即可连起来,而S颗卫星可以代替S-1条边,基于贪心思想,代替的边越长,求得的D就越小。所以可以用一个数组保存加入最小生成树的边的长度,共有P-1条边,如果从大到小排序,把前S-1条较长的边代替掉,剩下的边中最长的即为所求,即D=lu【s】,从小到大排序的话就把后面的S-1条边用卫星同道代替掉D=lu【top-S】。

Prime:

<pre name="code" class="cpp">#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
typedef long long ll;
using namespace std;
#define INF 1LL<<60
#define  N 550

int T,S,P,top;
int vis
;
double maps

,dis
;
double lu
; ///用来存放生成最小生成树的所有边
struct node
{
int x,y;
}p
;

void init()
{
int i,j;
for(i=0;i<N;i++)
for(j=0;j<N;j++)
maps[i][j]=maps[j][i]=(i==j)?0:INF;
}

double Dist(node a,node b)  ///求两点间的距离
{
return sqrt(1.0*(a.x-b.x)*(a.x-b.x)+1.0*(a.y-b.y)*(a.y-b.y));
}

void Prime()
{
int i,j,index;
double Min;
top=0;
for(i=1;i<=P;i++)
{
dis[i]=maps[1][i];
vis[i]=0;
}
vis[1]=1;
for(i=1;i<=P;i++)
{
Min=INF;
index=-1;
for(j=1;j<=P;j++)
{
if(!vis[j] && Min>dis[j])
{
Min=dis[j];
index=j;
}
}
if(index==-1)
break;
vis[index]=1;

lu[top++]=Min;  ///用来建树的边存在lu[]中.。。
for(j=1;j<=P;j++)
{
if(!vis[j] && dis[j]>maps[index][j])
dis[j]=maps[index][j];
}
}
}

int main()
{
int i,j;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&S ,&P);
init();
for(i=1;i<=P;i++)
{
scanf("%d%d",&p[i].x,&p[i].y);
for(j=1;j<i;j++)
{
maps[i][j]=maps[j][i]=Dist(p[i],p[j]);
}
}

Prime();
sort(lu,lu+top); ///sort将lu[]中的所有边从小到达排序
double ans=lu[top-S];  ///直接输出删除S-1条边后的最大值
printf("%.2lf\n",ans);
}
return 0;
}




Kruskal:

<pre name="code" class="cpp">#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
typedef long long ll;
using namespace std;
#define INF 1LL<<60
#define  N 550

int T,S,P,top,k;
int father
;
double lu
;
struct node   ///用来存放各个点坐标
{
int x,y;
}p
;

struct edge   ///存每条边的两个结点和距离
{
int u,v;
double w;
}e[N*N];

int cmp(edge a,edge b)
{
return a.w<b.w;
}

double Dist(node a,node b)
{
return sqrt(1.0*(a.x-b.x)*(a.x-b.x)+1.0*(a.y-b.y)*(a.y-b.y));
}

int Find(int x)
{
while(x!=father[x])
x=father[x];
return x;
}

int main()
{
int i,j,k;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&S,&P);

for(i=1;i<=P;i++)
father[i]=i;
for(i=1;i<=P;i++)
scanf("%d%d",&p[i].x,&p[i].y);

top=0;
for(i=1;i<=P;i++)
{
for(j=i+1;j<=P;j++)
{
e[top].u=i;
e[top].v=j;
e[top].w=Dist(p[i],p[j]);
top++;
e[top].u=j;
e[top].v=i;
e[top].w=Dist(p[i],p[j]);
top++;
}
}

sort(e,e+top,cmp);
k=0;
for(i=0;i<top;i++)
{
int x,y;
x=Find(e[i].u);
y=Find(e[i].v);
if(x==y)
continue;
else
{
if(x<y)
father[y]=x;
else
father[x]=y;

lu[k++]=e[i].w;
if(k==P-1)  /// 当找到P-1条边时 已经形成最小生成树,跳出
break;
}
}
printf("%.2f\n",lu[k-S]);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: