您的位置:首页 > 其它

hdoj 1709 The Balance <母函数变形--有点像找同因数--队列排数>

2016-07-22 16:30 162 查看


The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7476    Accepted Submission(s): 3103


Problem Description

Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

 

Input

The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

 

Output

For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

 

Sample Input

3
1 2 4
3
9 2 1

 

Sample Output

0
2
4 5

 

Source

HDU 2007-Spring Programming Contest

打表筛数---

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MA 10100
int m[MA],kp;
int shu[MA];
int main()
{
int n;
while (~scanf("%d",&n))
{
int s=0;
for (int i=0;i<n;i++)
{
scanf("%d",&shu[i]);
s+=shu[i];
}
kp=0;
memset(m,0,sizeof(m));
int qu[MA];
qu[kp++]=0;m[0]=1;
int a,b,c;
for (int i=0;i<n;i++)
{
int ll=kp;
for (int j=0;j<ll;j++)
{
if (!m[qu[j]+shu[i]])
{
qu[kp++]=qu[j]+shu[i];
m[qu[kp-1]]=1;
}
a=min(qu[j],shu[i]);
b=max(qu[j],shu[i]);
c=b-a;
if (!m[c])
{
qu[kp++]=c;
m[c]=1;
}
}
}
int ss=0;
for (int i=1;i<=s;i++)
if (!m[i])
ss++;
printf("%d\n",ss);
for (int i=1;i<=s;i++)
{
if (!m[i])
{
ss--;
if (ss)
printf("%d ",i);
else
printf("%d\n",i);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: