您的位置:首页 > 其它

HDU 2795 Billboard 线段树

2016-07-21 11:21 477 查看

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18490    Accepted Submission(s): 7747


[align=left]Problem Description[/align]
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

[align=left]Input[/align]
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

[align=left]Output[/align]
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.
 

[align=left]Sample Input[/align]

3 5 5
2
4
3
3
3

 

[align=left]Sample Output[/align]

1
2
1
3
-1

// 题意在一个H*W的公告板上贴按顺序贴一些广告 每贴一张(广告高度都是1) 都是靠上 靠左原则 依次输出广告贴的高度(1最高) 

// 线段树 20万张广告 建树(20万*4)   对每个高度的广告板的宽度进行消费  记录每个区间 大的没被用的宽度值

#include<stdio.h>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int str[200005*4];
int h,w,n;
int ans;
void build(int l,int r,int rt)
{
str[rt]=w;
if(l==r) return ;
int m=(l+r)>>1;
build(lson);
build(rson);

}

void query(int p,int l,int r,int rt) //查询更新 一起
{
if(l==r)
{
str[rt]=str[rt]-p; //更新
ans=l;
return ;
}
int m=(l+r)>>1;
if(p<=str[rt*2]) query(p,lson);
else if(p<=str[rt*2+1]) query(p,rson);
else return ;
str[rt]=max(str[rt<<1],str[rt<<1|1]); //更新
}

int main()
{ int p;
while(scanf("%d %d",&h,&w)!=EOF)
{ scanf("%d",&n);
build(1,n,1);
for(int i=1;i<=n;i++)
{scanf("%d",&p);
if(p>w) {printf("-1\n");continue;}
ans=-1;
query(p,1,n,1);

if(ans>h) printf("-1\n");
else printf("%d\n",ans);

}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: