您的位置:首页 > 其它

【杭电1002】A + B Problem II

2016-07-21 09:27 429 查看
A + B Problem II
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

I have a VERY SIMPLE problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
正整数高精度1000位加法

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input



2
1 2
112233445566778899 998877665544332211


Sample Output



Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int max(int a,int b)
{
int x;
x=a>b?a:b;
return x;
}
int main()
{
char a[1100],b[1100];
int z,i,n,la,lb,t=0,numa[1100],numb[1100];
scanf("%d",&n);
while(n--)
{
memset(numa,0,sizeof(numa));数组清零
memset(numb,0,sizeof(numb));
scanf("%s%s",&a,&b);
la=strlen(a);
lb=strlen(b);
for(i=0;i<la;i++)
numa[la-1-i]=a[i]-'0';
for(i=0;i<lb;i++)
numb[lb-1-i]=b[i]-'0';字符转化为数字

z=max(la,lb);
for(i=0;i<z;i++)
{
numa[i]=numa[i]+numb[i];
if(numa[i]>9)
{
numa[i]=numa[i]-10;
numa[i+1]++;进位
}
}
t++;
printf("Case %d:\n",t);
printf("%s + %s = ",a,b);
if(numa[z]==0)
{
for(i=z-1;i>=0;i--)
printf("%d",numa[i]);
printf("\n");
}
else
{
for(i=z;i>=0;i--)
printf("%d",numa[i]);
printf("\n");
}
if(n!=0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: