您的位置:首页 > 其它

F - The MAX(sort)

2016-07-20 09:01 169 查看

F - The MAX(sort)

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.

Input

Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2….Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.

Output

For each test case, output the biggest value of F you can find on a line.

Sample Input

2

1 2

0

Sample Output

4017

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;

int a[1111];

int max(long long a,long long b)
{
return a>b?a:b;
}

int main()
{

long long s,i,j,m,n,cnt,k=0,c,l;//数据短吗 为毛溢出
while(scanf("%lld",&n),n)
{
s=0;
m=0;
for(i=1;i<=n;++i)
{
cin>>a[i];
s+=a[i];
m=max(a[i],m);
}

s+=m*(2009-n+1)-m;

cout<<s<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: