您的位置:首页 > 其它

HDOJ 5499 SDOI(典型的翻译题目,处理女生特殊情况的问题)

2016-07-19 21:24 344 查看



SDOI(粘贴有误,点击进入原题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 902    Accepted Submission(s): 360


Problem Description

The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. n(n≤100) people
comes to the Select and there is m(m≤50) people
who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is 300.

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is x.(it
is promised that not all person in one round is 0,in another way,x>0).
So for this round,everyone's final mark equals to his/her original mark∗(300/x).

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as 0.3∗round1′s final
mark + 0.7∗round2′s final
mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.

2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.

 

Input

There is an integer T(T≤100) in
the first line for the number of testcases and followed T testcases.

For each testcase, there are two integers n and m in
the first line(n≥m),
standing for the number of people take part in SDOI and the allowance of the team.Followed with n lines,each
line is an information of a person. Name(A string with length less than 20,only
contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than 300)
separated with a space.

 

Output

For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed m lines,every
line is the name of the team with their Ultimate mark decreasing.

 

Sample Input

2
10 8
dxy male 230 225
davidwang male 218 235
evensgn male 150 175
tpkuangmo female 34 21
guncuye male 5 15
faebdc male 245 250
lavender female 220 216
qmqmqm male 250 245
davidlee male 240 160
dxymeizi female 205 190
2 1
dxy male 300 300
dxymeizi female 0 0

 

Sample Output

The member list of Shandong team is as follows:
faebdc
qmqmqm
davidwang
dxy
lavender
dxymeizi
davidlee
evensgn
The member list of Shandong team is as follows:
dxymeizi

Hint
For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2.
The Final of The Ultimate score is as followed
faebdc 298.20
qmqmqm 295.80
davidwang 275.88
dxy 271.80
lavender 260.64
dxymeizi 233.40
davidlee 220.80
evensgn 201.00
tpkuangmo 29.88
guncuye 14.40

For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.

 

Source

BestCoder Round #59 (div.2)

翻译:就是有  n 个人选出来 m 个人参加比赛。要求挺多的昂。

两场比赛的评分标准:本局得分 * ( 300 / 最高分 );

有女生必须要参加,并且名次不能乱;

看注释吧。(渣渣的英语不好意思说翻译)

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

struct STU {
char name[128];
char gender[16];//性别
double g1;//第一场得分
double g2;//第二场得分
double sum;//总得分 0.3*g1+0.7*g2
//	int select;
} xs[MYDD];

bool cmp_sum(STU x,STU y) {
return x.sum>y.sum;
}

int main() {
int T,n,m;// n 个人选 m个
double max1,max2;
int have_gril;//判断队员有无女性
int get_gril;//选中的队员有无女性
scanf("%d",&T);
while(T--) {
scanf("%d%d",&n,&m);
max1=max2=0;
have_gril=0;
for(int j=0; j<n; j++) {
scanf("%s%s%lf%lf",xs[j].name,xs[j].gender,&xs[j].g1,&xs[j].g2);
if(xs[j].g1>max1)//寻找第一场的最高分
max1=xs[j].g1;
if(xs[j].g2>max2)//寻找第二场的最高分
max2=xs[j].g2;
if(strcmp(xs[j].gender,"female")==0)
have_gril=1;//有女生
//xs[j].select=1;//用于标记选择的女生
}

for(int j=0; j<n; j++) {
xs[j].sum=0.3*xs[j].g1*(300.0/max1)+0.7*xs[j].g2*(300.0/max2);
}

sort(xs,xs+n,cmp_sum);

puts("The member list of Shandong team is as follows:");

get_gril=0;
if(have_gril) {
for(int j=0; j<m; j++)
if(strcmp(xs[j].gender,"female")==0) {
get_gril=1;//选择的队员有女生
break;
}
if(get_gril) {//选择的队员有女生就直接输出结果
for(int j=0; j<m; j++)
printf("%s\n",xs[j].name);
}

int DanD;//用于寻找排名比较靠前的女生
if(!get_gril) {//选择的队员没有女生
for(int j=0; j<n; j++)
if(strcmp(xs[j].gender,"female")==0) {
DanD=j;//找到分数最高的女生替换队伍中分数最少的一个男生
break;
}
for(int j=0; j<m-1; j++)
printf("%s\n",xs[j].name);
printf("%s\n",xs[DanD].name);
}
} else {
for(int j=0; j<m; j++)
printf("%s\n",xs[j].name);
}
}
return 0;
}

/*

3
2 1
dxy male 300 300
dxymeizi female 0 0

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: