您的位置:首页 > 其它

HDU 1240 Asteroids!【BFS】

2016-07-19 20:26 399 查看


Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4763    Accepted Submission(s): 3061


Problem Description

You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.

 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

 

Sample Output

1 0
3 4
NO ROUTE

 

Source

South Central USA 2001

 

#include<stdio.h>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;

int flag,minn;
int x1,x2,y1,y2,z1,z2;
int step[6][3]= {0,1,0,
1,0,0,
-1,0,0,
0,-1,0,
0,0,1,
0,0,-1
};
bool vis[15][15][15];
int n;
char map[15][15][15];
struct node
{
int x,y,z,t;
};
bool check(node no)
{
if(no.x<0||no.x>=n||no.y<0||no.y>=n||no.z<0||no.z>=n)
return false;
return true;
}
int BFS()
{
node a,next;
queue<node> q;
memset(vis,false,sizeof(vis));
vis[z1][x1][y1]=true;
a.x=x1;
a.y=y1;
a.z=z1;
a.t=0;
q.push(a);
while(!q.empty())
{
a=q.front();
q.pop();
if(a.x==x2&&a.y==y2&&a.z==z2)//=少输入了一个
{
return a.t;
}
for(int i=0; i<6; i++)
{
//printf("111\n");
next.x=a.x+step[i][0];
next.y=a.y+step[i][1];
next.z=a.z+step[i][2];
if(check(next)&&!vis[next.z][next.x][next.y]&&map[next.z][next.x][next.y]!='X')
{
vis[next.z][next.x][next.y]=true;
next.t=a.t+1;
q.push(next);
}
}
}
return -1;
}
int main (void)
{
char str[10],str2[10];
while(~scanf("%s%d",str,&n))
{
getchar();
for(int i=0; i<n; i++)
{
for(int ii=0; ii<n; ii++)
{
for(int iii=0; iii<n; iii++)
{
scanf("%c",&map[i][ii][iii]);
}
getchar();
}
}
scanf("%d%d%d",&y1,&x1,&z1);
scanf("%d%d%d",&y2,&x2,&z2);
scanf("%s",str2);
minn=BFS();
if(minn!=-1)
printf("%d %d\n",n,minn);
else
printf("NO ROUTE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: