您的位置:首页 > 其它

Milk(sort+结构体)

2016-07-19 18:03 232 查看
Milk(sort+结构体)

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u

SubmitStatus

Description

Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:

1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).

2. Ignatius drinks 200mL milk everyday.

3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.

4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than
200mL, you should ignore it.

Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan)
which is the price of a bottle, V( mL) which is the volume of a bottle.

Output

For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

Sample Input

2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000


Sample Output

Mengniu
Mengniu


Hint

In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
题意:
给出n种牛奶的价格,和量,问,哪一种最便宜,若相同,输出量最多的那个:
规则:
一天喝200ml,一瓶不能超过5天,瓶剩少于200时扔掉;
代码:
[code]#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct p
{
char num[1000];
int c,a,k;
double d;
}b[1000];
bool cmp(p a,p b)
{

if(a.d==b.d)
return a.k>b.k;
return a.d<b.d;
}
int main()
{
int n,m;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%s %d %d",b[i].num,&b[i].a,&b[i].k);
b[i].c=b[i].k/200;
if(b[i].c>5)
b[i].c=5;
b[i].d=(double)b[i].a/(double)b[i].c;

}
sort(b,b+m,cmp);
printf("%s\n",b[0].num);
}
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: