您的位置:首页 > 其它

poj3295

2016-07-19 15:23 357 查看
Tautology

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11633 Accepted: 4409
Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the
value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0

Sample Output
tautology
not


借助栈来进行运算

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
char s[400];
int stac[1000];
int top=-1;
int put(char a,int pp,int qq,int rr,int ss,int tt){
switch(a){
case 'p':top++;stac[top]=pp;return 1;
case 'q':top++;stac[top]=qq;return 1;
case 'r':top++;stac[top]=rr;return 1;
case 's':top++;stac[top]=ss;return 1;
case 't':top++;stac[top]=tt;return 1;
}
return 0;
}
void oprand(char a){
int x,y;
switch(a){
case 'K':{
x=stac[top];
top--;
y=stac[top];
stac[top]=(x&&y);
break;
}
case 'A':{
x=stac[top];
top--;
y=stac[top];
stac[top]=(x||y);
break;
}
case 'N':{
x=stac[top];
stac[top]=(!x);
break;
}
case 'C':{
x=stac[top];
top--;
y=stac[top];
stac[top]=((!x)||y);
break;
}
case 'E':{
x=stac[top];
top--;
y=stac[top];
stac[top]=(x==y);
break;
}
}
return;
}
int main(){
int i,j;
int len;
int pp,qq,rr,ss,tt;
int ans;
int flag;
while(~scanf("%s",s)){
if(s[0]=='0')break;
len=strlen(s);
flag=1;
for(pp=0;pp<=1;pp++){
for(qq=0;qq<=1;qq++){
for(rr=0;rr<=1;rr++){
for(ss=0;ss<=1;ss++){
for(tt=0;tt<=1;tt++){
for(i=len-1;i>=0;i--){
if(put(s[i],pp,qq,rr,ss,tt)==0){
oprand(s[i]);
}
}
ans=stac[top];
if(!ans){
flag=0;
break;
}
}
if(!flag){
break;
}
}
if(!flag){
break;
}
}
if(!flag){
break;
}
}
if(!flag){
break;
}
}
if(flag)
printf("tautology\n");
else printf("not\n");
top=-1;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj