您的位置:首页 > 其它

hdoj1002A + B Problem II

2016-07-19 08:01 232 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 314386    Accepted Submission(s): 60948


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 
一个大数相加问题用字符数组储存然后转移int型计算。

#include<cstdio>
#include<cstring>
#include<cstdlib>
int main(){
char str1[1010],str2[1010];
int a[1010] = {0},b[1010] = {0};
int length1,length2;
int z;
int t;
int l=1;
scanf("%d",&t);
while(t --){
scanf("%s%s",str1,str2);
memset(a,0,sizeof(a));//清零数组
memset(b,0,sizeof(b));
length1 = strlen(str1);
length2 = strlen(str2);
for(int i = 0;i < length1;i ++)//反向存储容易进位
a[length1-i-1] = str1[i] - '0';
for(int i = 0;i < length2;i ++)
b[length2-i-1] = str2[i]- '0';

if(length1 > length2)
z = length1;
else
z = length2;
int p=0,q=0;
for(int i = 0;i <= z;i ++){
q = a[i]+b[i]+p;//进位设置
a[i] = q % 10;
p = q / 10;
}
printf("Case %d:\n",l);
printf("%s + %s = ",str1,str2);
if( a[z] ){
printf ( "%d",a[z] );
}
for( int i = z - 1;i >= 0;i -- )
printf( "%d", a[i] );
printf( "\n" );
if(t)
printf("\n");
l++;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: