您的位置:首页 > 数据库 > Oracle

hdu 5718 Oracle(模拟)

2016-07-17 22:48 483 查看


Oracle

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 43    Accepted Submission(s): 22


Problem Description

There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask
for an oracle.

The oracle is an integer n without
leading zeroes. 

To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible. 

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.

 

Input

The first line of the input contains an integer T (1≤T≤10),
which denotes the number of test cases.

For each test case, the single line contains an integer n (1≤n<1010000000).

 

Output

For each test case, print a positive integer or a string `Uncertain`.

 

Sample Input

3
112
233
1

 

Sample Output

22
35
Uncertain

Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $.

In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $.

In the third example, it is impossible to split single digit $ 1 $ into two parts.

 

Source

BestCoder 2nd Anniversary
题意:给一个有10000000长的没有前导零的正整数,将这个大整数重新排列然后分裂成两个正整数,求最大的正整数之和

思路:  如果可以分裂成两个正整数,那么其中一个肯定是最小的非0个位数,把字符串从大到小进行排序,我们肯定是取最小的非0那一位出来。这应该是显而易见的

然后只需要模拟就好了。 注意大整数进位的判断

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 10000050
char s
;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%s",&s);
int len =strlen(s);
sort(s,s+len);
int k;
int num=0;
for(int i=0; i<len; i++)
if(s[i]>'0')
num++;
if(num<2||len<2) printf("Uncertain\n");
else
{
int m;
for(k=0; k<len; k++)
if(s[k]>'0')
{
m=s[k]-'0';
for(int j=k+1; j<len; j++)
s[j-1]=s[j];
break;
}
s[len-1]='0';
if(s[0]+m<='9') s[0]+=m;
else
{
s[0]=s[0]+m-10;
s[1]++;
for(int i=1; i<len-1; i++)
{
if(s[i]<='9') break;
s[i]=s[i]-'10';
s[i+1]++;
}
}
if(s[len-1]>'0') printf("1");
for(int i=len-2;i>=0;i--)
printf("%c",s[i]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: