您的位置:首页 > 其它

UVA 1149 bin packing (贪心)

2016-07-17 16:20 344 查看
A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that 
each bin contains at most 2 items, 

each item is packed in one of the q bins, 

the sum of the lengths of the items packed in a bin does not exceed l . 

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q . 


Input 

The first line of the input contains the number of items n (1<=n<=105) . The second line contains one integer
that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items. 


Output 

Your program has to write the minimal number of bins required to pack all items. 


Sample Input 

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output 

6

一.分析

二.代码

//
//  main.cpp
//  Uva1149
//
//  Created by 张嘉韬 on 16/7/17.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
void print (int *l,int n)
{
for(int i=0;i<n;i++)
{
cout<<l[i]<<" ";
}
}
int main(int argc, const char * argv[]) {
//freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
int n,L,l[100010],counter;
counter=0;
cin>>n>>L;
for(int i=0;i<n;i++) cin>>l[i];
sort(l+0,l+n);
//print(l,n);
int left,right;
left=0,right=n-1;
while(left<=right)
{
if(l[left]+l[right]<=L)
{
left++;
right--;
}
else right--;
counter++;
}
cout<<counter<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: