您的位置:首页 > 运维架构

POJ 3050——Hopscotch(dfs,爆搜)

2016-07-17 11:35 363 查看
题目:

Hopscotch

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3239 Accepted: 2245
Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.
Input

* Lines 1..5: The grid, five integers per line
Output

* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output
15

Hint

OUTPUT DETAILS: 

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题目大意:给个矩阵,从任意起点出发。向左向右向上向下看能组成多少个六位数,可以有前导零。

思路:直接暴力搜索即可

代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <cctype>
#include <string>
#include <map>
#include <set>
#include <iostream>
using namespace std;

#define INF 1e9+7
#define MAXN 100010

int a[5][5];

int shift(int temp[])
{
int s=0;
for(int k=0;k<6;k++)
{
s=s*10+temp[k];
}
return s;
}

set <int> res;
int temp[6];
int dx[]={1,0,-1,0};
int dy[]={0,1,0,-1};

void dfs(int x,int y,int cur)
{
if(cur==6)
{
int ans=shift(temp);
res.insert(ans);
return;
}
temp[cur]=a[x][y];
for(int i=0;i<4;i++)
{
int ex=x+dx[i];
int ey=y+dy[i];
if(ex>=0&&ex<5&&ey>=0&&ey<5)
{
dfs(ex,ey,cur+1);
}
}
}

int main()
{
for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
scanf("%d",&a[i][j]);
for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
{
dfs(i,j,0);
}
printf("%d\n",(int)res.size());
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: