您的位置:首页 > 产品设计 > UI/UE

hdu_1711Number Sequence(kmp)

2016-07-16 15:03 375 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20445 Accepted Submission(s): 8756


[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

[align=left]Sample Output[/align]

6
-1
赤裸裸的kmp

//kmp
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000005],b[10005];
int Next[10005];
int n,m;
int kmp()
{
int i,j;
j = 0;
int tm = Next[0] = -1;
//ÇóNextÊý×é
while(j<m-1){
if(tm<0||b[j]==b[tm])
Next[++j] = ++tm;
else tm = Next[tm];
}
//Æ¥Åä
for( i = j = 0; i < n&&j < m; ){
if(j<0||a[i]==b[j])i++,j++;
else j = Next[j];
}
if(j<m) return -1;
return i-j;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i = 0; i< n; i++)
scanf("%d",&a[i]);
for(int i = 0; i < m; i++)
scanf("%d",&b[i]);
int ans = kmp();
if(ans!=-1)
printf("%d\n",ans+1);
else puts("-1");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: