您的位置:首页 > 其它

HDU 1007 Quoit Design(最近点对问题:分治)

2016-07-12 15:54 447 查看

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45777    Accepted Submission(s): 11913


[align=left]Problem Description[/align]
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.

In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a
configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered
to be 0.

[align=left]Input[/align]
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x,
y) which are the coordinates of a toy. The input is terminated by N = 0.

[align=left]Output[/align]
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

[align=left]Sample Input[/align]

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

[align=left]Sample Output[/align]

0.71
0.00
0.75

[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1009 1011 1024 1018 1023 

题意:给你平面上的一堆点,然后求其中两个点之间的最短距离。

题解:分治问题,最近点对问题。
           距离最小的两个点A、B,一定满足条件:B必然是A按X或Y轴排序最短的点,故只要分别按X、Y轴排序,分别            计算出每一点按X、Y轴最近的点的距离,取最小值即可。

AC代码:
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct point
{
double x,y;
}a[100001];
bool compare1(const point &a,const point &b)
{
if(fabs(a.x-b.x)<1e-8)
return a.y < b.y;
return a.x<b.x;

}
bool compare2(const point &a,const point &b)
{
if(fabs(a.y-b.y)<1e-8)
return a.x < b.x;
return a.y<b.y;

}

int main()
{
int n;
double k,s;
while(~scanf("%d\n",&n)&&n)
{
k=11111111;
for(int i=0;i<n;i++)
{
scanf("%lf %lf",&a[i].x,&a[i].y);
}
sort(a,a+n,compare1);
for(int i=0;i<n-1;i++)
{
s=sqrt((a[i].x-a[i+1].x)*(a[i].x-a[i+1].x)+(a[i].y-a[i+1].y)*(a[i].y-a[i+1].y));
if(k>s)
k=s;
}
sort(a,a+n,compare2);
for(int i=0;i<n-1;i++)
{
s=sqrt((a[i].x-a[i+1].x)*(a[i].x-a[i+1].x)+(a[i].y-a[i+1].y)*(a[i].y-a[i+1].y));
if(k>s)
k=s;
}
printf("%.2lf\n",k/2);

}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: