您的位置:首页 > 产品设计 > UI/UE

POJ-2081-Recaman's Sequence

2016-07-12 14:23 309 查看
Time Limit: 3000MS      Memory Limit: 60000K
Total Submissions: 22786        Accepted: 9821


Description

The Recaman’s sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m.

The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 …

Given k, your task is to calculate ak.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.

The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing ak to the output.

Sample Input

7

10000

-1

Sample Output

20

18658

题意说明:给你个数a[0]=0 当a[m-1]-m>0 并且这个式子求出来的数并未出现过,那么 am = am−1 − m,否则am = am−1 + m.

解题思路:这个不就不用多说了,为了节省时间,在输入前就应该遍历好这个数列,因为输出的数是不超过50W的,所有我们要遍历前50W个 中间要开个数组来记录出现过得数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <map>
#include <cmath>
#include <queue>
using namespace std;
int k;
int vis[5000005];//因为这50W中的数有些数很大 故要开这么大
int dp[500005];//记录的数组
int main()
{
memset(vis,0,sizeof(vis));//初始化记录出现的数的数组
memset(dp,0,sizeof(dp));//初始化
dp[0]=0;//a[0]=0;
vis[dp[0]]=1;//标记0出现过
for(int i=1;i<=500000;i++)
{
if(dp[i-1]-i>0&&!vis[dp[i-1]-i]){//满足条件
dp[i]=dp[i-1]-i;
vis[dp[i]]=1;//记录出现过
}
else{
dp[i]=dp[i-1]+i;
vis[dp[i]]=1;//记录出现过
}
}
while(~scanf("%d",&k))
{
if(k==-1)
break;
printf("%d\n",dp[k]);
}
return 0;
}


END!!!!!!!!!!!!!!!!!!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: