您的位置:首页 > 其它

HDU1548:A strange lift(BFS)

2016-07-11 15:41 281 查看

HDU1548:A strange lift(BFS)

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 49   Accepted Submission(s) : 22

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki
floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding
with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as
you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0


Sample Output

3


原题:http://acm.hdu.edu.cn/showproblem.php?pid=1548

代码:

#include<iostream>

#include<cstring>

#include<queue>

using namespace std;

int n,a,b,f;

int step[205],vis[205];//step数组记录每一层一次上下的层数,vis数组记录是否访问过,顺便记录步数

bool cheak(int i)

{

    if(vis[i]==0&&i>=1&&i<=n)

        return true;

    return false;

}

int bfs()

{

    queue<int> q;

    q.push(a);

    vis[a]=1;

    while(!q.empty())

    {

        f=q.front();q.pop();

        if(f==b)

        {

            return vis[f];

        }

        if(cheak(f+step[f]))

        {

            q.push(f+step[f]);

            vis[f+step[f]]=vis[f]+1;

        }

        if(cheak(f-step[f]))

        {

            q.push(f-step[f]);

            vis[f-step[f]]=vis[f]+1;

        }

    }

    return 0;

}

int main()

{

    while(cin>>n)

    {

        if(n==0)

            break;

        cin>>a>>b;

        for(int i=1;i<=n;i++)

            cin>>step[i];

        memset(vis,0,sizeof(vis));

        int ans=bfs()-1;

        cout<<ans<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs