您的位置:首页 > 其它

PAT (Advanced Level) Practise 1001 A+B Format (20)

2016-07-09 19:20 323 查看


1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9

Sample Output

-999,991

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<iostream>
#include<stack>
#include<algorithm>
#include<bitset>
#include<functional>
#include<ctime>
using namespace std;
typedef unsigned long long ull;
typedef long long LL;
const int maxn = 1e3 + 10;
const int INF = 0x7FFFFFFF;
int a, b, c, flag, s[maxn], tot = 0;

int main()
{
scanf("%d%d", &a, &b);
c = a + b;  if (c < 0) { flag = 1; c = -c; }
while (c) s[tot++] = c % 10, c /= 10;
if (flag) printf("-");
for (int i = tot - 1; i >= 0; i--)
{
printf("%d", s[i]);
if (i % 3 == 0 && i) printf(",");
}
if (!tot) printf("0");
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: