您的位置:首页 > 其它

poj 2739 Sum of Consecutive Prime Numbers(尺取法)

2016-07-07 21:27 411 查看
Sum of Consecutive Prime Numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22876 Accepted: 12509
Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has
three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 

Your mission is to write a program that reports the number of representations for the given positive integer.
Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted
in the output.
Sample Input
2
3
17
41
20
666
12
53
0

Sample Output
1
1
2
3
0
0
1
2

题意:每一个数都可以由连续的质数相加得到,给一个数n,问一共有多少个质数序列和为n
思路:先存下所有的质数,因为质数是有序的,我们就可以用尺取法去枚举了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 11111
int a
,vis
;
int cnt;
void init()
{
cnt=0;
memset(vis,0,sizeof(vis));
for(int i=2;i<=10000;i++)
{
if(vis[i]) continue;
a[cnt++]=i;
for(int j=i*i;j<=10000;j+=i)
vis[j]=1;
}
}
int main()
{
init();
int n;
while(~scanf("%d",&n)&&n)
{
int l=0,r=0;
int mat=0,ans=0;
for(int i=0;i<cnt;i++)
{
if(a[i]>n) break;
while(r<cnt&&mat<n)
{
mat+=a[r];
r++;
}
if(mat==n) ans++;
mat-=a[l++];
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: