您的位置:首页 > 其它

POJ 2663 Tri Tiling

2016-07-05 23:24 274 查看
Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 

Here is a sample tiling of a 3x12 rectangle. 



Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input
2
8
12
-1


Sample Output
3
153


分析:这是一道思维训练的好题。分两种情况考虑

1.在此处放一单位的积木。等于 3 * DP[i-1];

      2.与前面相连接。连接的方案有 2 * (DP[i-2] + DP[i-3] +......+ DP[0]);

      因此有:DP[i] = 3 * DP[i-1] + 2 * (DP[i-2] + DP[i-3] +......+ DP[0]);

      理解到这里应该就差不多了,当然也可以再化简为 DP[i] = 4 * DP[i-1] - DP[i-2];



#include <iostream>

using namespace std;

int main()
{
long long a[32];
int n;
a[0] = 1; a[2]= 3;a[1] = 0;
for(long long i =3 ;i<31;i++)
{
if(i&1)
a[i] = 0;
else
{
a[i] = 4*a[i-2] - a[i-4];
}
//cout << i<< "  "<< a[i] <<endl;
}
while(cin>>n)
{
if(n == -1)
break;
cout << a
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: