您的位置:首页 > 其它

The Triangle

2016-07-05 18:00 162 查看
Problem Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.

 

Output

Your program is to write to standard output. The highest sum is written as an integer.

 

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

 

Sample Output

30

简单的动态归划

#include <iostream>
using namespace std;
int Max(int a,int b);
int main()
{
int n,dp[105][105];
cin>>n;
int i,j;
for(i=0;i<n;i++){
for(j=0;j<=i;j++){
cin>>dp[i][j];
}
}
for(i=n-2;i>=0;--i){
for(j=0;j<=i;++j){
dp[i][j]=dp[i][j]+Max(dp[i+1][j],dp[i+1][j+1]);
}
}
cout << dp[0][0] << endl;
return 0;
}
int Max(int a,int b){
return (a>b?a:b);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: