您的位置:首页 > 其它

poj1837 Balance (二维费用背包&&分组背包)

2016-07-02 00:58 375 查看
Balance

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 13009 Accepted: 8152

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.

It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);

• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4

-2 3

3 4 5 8

Sample Output

2

解题:

这道题我开始思考的是用一维的去解这道题,后来发现怎么也实现不了。

后来才知道是用二维的,发蠢。。

可能还是题目做的少,这里的背包明显受到了两个条件的限制,一个是砝码,一个是重量。

对于砝码,使用一维的后果就是,你在挂在A位置的砝码之后,同样的挂在B位置的砝码可能也受到了A位置砝码的影响,对于某一个重量j,假设某个砝码X的重量是w,好,现在j-w受到了这个砝码的影响。然后因为是一维,当循环到重量j-1的时候,又到了这个砝码X的影响,然后刚刚受到你j-w又继续去祸害别人了!这不行!

你能说你这一个砝码一个循环还可以搞了几次??

使用二维就不会带来这样的影响,因为我的第i砝码都是由先前的i-1砝码推导而来的。

代码:

#include<cstdio>
#include<iostream>
using namespace std;
#include<cstring>
#include<algorithm>

#define si(x) scanf("%d",&(x))
#define sii(x,y) scanf("%d%d",&(x),&(y))
#define cls(x,y) memset((x),(y),sizeof((x)));
const int maxn=25;
int G[maxn],C[maxn];

/*
题目大意:
有一个天平,天平左右两边各有若干个钩子,总共有C个钩子,有G个钩码,求将钩码全部挂到钩子上使天平平衡的方法的总数
其中可以把天枰看做一个以x轴0点作为平衡点的横轴
输入

2 4 //C 钩子数 与 G钩码数
-2 3 //负数:左边的钩子距离天平中央的距离;正数:右边的钩子距离天平中央的距离c[k]
3 4 5 8 //G个重物的质量w[i]
*/
int n,m;

const int mid=8000;
int dp[maxn][(mid<<1)+15];

int main() {
#ifdef tangge
freopen("1837.txt","r",stdin);
#endif
while(~scanf("%d%d",&n,&m)) {
for(int i=1; i<=n; ++i)si(C[i]);
for(int i=1; i<=m; ++i)si(G[i]);
cls(dp,0)
dp[0][mid]=1;
for(int i=1; i<=m; ++i) {
for(int j=mid<<1; j>=0; --j) {
for(int k=1; k<=n&&dp[j]>0; ++k) {
int t=C[k]*G[i];
if(j-t>=0&&j-t<=(mid<<1)) {
dp[i][j]+=dp[i-1][j-t];
}
}
}
}
//        for(int i=1;i<=m;++i){
//            for(int j=mid<<1;j>=0;--j){
//                for(int k=1;k<=n&&dp[j]>0;++k){
//                    int t=C[k]*G[i];
//                    if(j+t>=0&&j+t<=(mid<<1)){
//                        dp[j+t]+=dp[j];
////                        if(dp[j]>0)cout<<"wieght="<<j<<" value="<<dp[j]<<endl;
//                    }
//                }
//            }
//        }
//        int ans=0;
//        for(int i=0;;++i){
//            if(mid-i>=0&&mid+i<=(mid<<1)){
//                int t=min(dp[mid+i],dp[mid-i]);
//                if(t>0)ans+=t;
//                if(min(dp[mid+i],dp[mid-i])>0)cout<<"l="<<mid-i<<" r="<<mid+i<<" ans="<<ans<<endl;
//            }else break;
//        }
printf("%d\n",dp[m][mid]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: