您的位置:首页 > 其它

输入正整数k,找到所有的正整数x>=y,使得1/k=1/x + 1/y; 样例输入: 2 12 样例输出: 2 1/2 = 1/6 + 1/3 1/

2016-07-01 18:14 706 查看
import java.util.*;

class Fenshu
{
static Scanner scan=new Scanner(System.in);
public static void main(String[] args)
{
int k;
int x,y;
int maxn=10000;
int[] a=new int[maxn];
int[] b=new int[maxn];
k=scan.nextInt();
int count,i,j;
while(k!=0)
{
count=i=j=0;
Arrays.fill(a,0);
Arrays.fill(b,0);
for( y=k+1;y<=2*k;y++)
{
if((y*k)%(y-k)==0)
{

count++;
a[i++]=(y*k)/(y-k);
b[j++]=y;

}
}

for(int l=0;l<count;l++)
{
System.out.print("1/");
System.out.print(k);
System.out.print("=");
System.out.print("1/");
System.out.print(a[l]);
System.out.print("+");
System.out.print("1/");
System.out.println(b[l]);
}
k=scan.nextInt();
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  class