您的位置:首页 > 其它

ACM专题四1001

2016-07-01 08:57 148 查看

[align=left]Problem Description[/align]
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected. <br><br>We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length
of all the roads built is minimum.<br>
 

[align=left]Input[/align]
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.<br><br>Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.<br>
 

[align=left]Output[/align]
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. <br>
 

[align=left]Sample Input[/align]

3
0 990 692
990 0 179
692 179 0
1
1 2

 
[align=left]Sample Output[/align]

179

[align=left](1)大意:有n个村庄,编号从1到n,你应该建立一些道路,使得每两个村庄可以相互连接。我们说两个村A和B是连接的,如果只有在A和B之间有一条路,或有一个C和C之间有一条路,C和B之间有一条路。一些村庄之间原有一些道路,现在建立一些道路,使得所有的村庄都连接,求所有的道路的长度是最小的。[/align]
[align=left](2)思路:[/align]
[align=left]我用的最小生成树的解法,prim算法,代码如下,当然贪心+并查集也可以的。[/align]
[align=left](3)感想:[/align]
[align=left]  因为一看是英文的,所以没做之前,但是做了几道以后,发现 1001却是最简单的,而且课堂上也讲了,用贪心跟并查集的方法。[/align]
[align=left](4)代码:[/align]
#include<iostream>

#include<cstdio>

#include<cstring>
[align=left]using namespace std;[/align]
const int N=110;

const int INF=0x3f3f3f3f;
int n,ans;

int map

,dis
,vis
;
void Prim(){

    int i;

    for(i=1;i<=n;i++){

        dis[i]=map[1][i];

        vis[i]=0;

    }

    dis[1]=0;

    vis[1]=1;

    int j,k,tmp;

    for(i=1;i<=n;i++){

        tmp=INF;

        for(j=1;j<=n;j++)

            if(!vis[j] && tmp>dis[j]){

                k=j;

                tmp=dis[j];

            }

        if(tmp==INF)

            break;

        vis[k]=1;

        ans+=dis[k];

        for(j=1;j<=n;j++)

            if(!vis[j] && dis[j]>map[k][j])

                dis[j]=map[k][j];

    }

}
[align=left]int main(){[/align]
[align=left]    //freopen("input.txt","r",stdin);[/align]
    while(~scanf("%d",&n)){

        for(int i=1;i<=n;i++)

            for(int j=1;j<=n;j++)

                scanf("%d",&map[i][j]);

        int q,a,b;

        scanf("%d",&q);

        while(q--){

            scanf("%d%d",&a,&b);

            map[a][b]=map[b][a]=0;

        }

        ans=0;

        Prim();

        printf("%d\n",ans);

    }

    return 0;

}
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: