您的位置:首页 > 其它

Six Degrees of Cowvin Bacon poj 2131(floyd)

2016-06-27 10:45 375 查看
问题描述

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.

输入

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.

输出

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

样例输入

4 2
3 1 2 3
2 3 4


样例输出

100


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

const int INF=999999999;
int ma[302][302];

int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
ma[i][j]=INF;

for(int i=1;i<=m;i++)
{
int k;
scanf("%d",&k);
int tem[302];
for(int j=1;j<=k;j++)
{
scanf("%d",&tem[j]);
}
for(int j=1;j<=k;j++)
for(int l=j+1;l<=k;l++)
ma[tem[j]][tem[l]]=ma[tem[l]][tem[j]]=1;
}

for(int k=1;k<=n;k++)
for(int j=1;j<=n;j++)
for(int i=1;i<=n;i++)
ma[i][j]=min(ma[i][k]+ma[j][k],ma[i][j]);

int ans=INF;
for(int i=1;i<=n;i++)
{
int ans1=0;
for(int j=1;j<=n;j++)
{
if(i!=j)
{
ans1+=ma[i][j];
}
}
ans=min(ans,ans1);
}
printf("%d\n",ans*100/(n-1));

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: