您的位置:首页 > 其它

hdu 1051 //多次贪心 (水题)

2016-06-23 21:03 281 查看
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17543    Accepted Submission(s): 7169

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

Source
Asia 2001, Taejon (South Korea)


#include <stdio.h>
#include <stdlib.h>
#define HIGH 5000
typedef struct
{
int L,W;
int flag;
}stick;
stick A[HIGH+1];
int cmp(const void *a,const void *b)
{
stick *A= (stick *)a, *B =(stick *)b;
if(A->L!=B->L) return A->L-B->L;
else           return A->W-B->W;
}
int  Cal(int n)
{
int count=0,E=0;
while(E!=n)
{
count++;
int L=0,W=0;
for(int i=1;i<=n;i++)
{
if(!A[i].flag&&A[i].L>=L&&A[i].W>=W)
{
L=A[i].L;
W=A[i].W;
A[i].flag=1;
E++;
}
}
}
return count;
}
int main()
{
int T;scanf("%d",&T);
for(int j=1;j<=T;j++)
{
int n;scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d %d",&A[i].L,&A[i].W);
A[i].flag=0;
}
qsort(A+1,n,sizeof(A[0]),cmp);
printf("%d\n",Cal(n));
}
return 0;
}


//思路很简单 ,以L为主,W为辅,多次贪心 ;(没有算时间复杂度,有点怕超时)

//可以以W为主,L为辅 也AC了
这里写代码片
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: