您的位置:首页 > 其它

hdoj-1098-Ignatius's puzzle

2016-06-12 20:07 281 查看
Problem Description

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if

no exists that a,then print “no”.

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output

The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input

11

100

9999

Sample Output

22

no

43

题目的关键是函数式f(x)=5*x^13+13*x^5+k*a*x; 用数学归纳法证明:x取任何值都需要能被65整除..

所以我们只需找到f(1)成立的a,并在假设f(x)成立的基础上,

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int k,i;
while(scanf("%d",&k)!=EOF)
{
for(i=1;i<=10000;i++)
{
if((18+k*i)%65==0)
{
printf("%d\n",i);break;
}
}
if(i>10000)printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: