您的位置:首页 > 其它

nyoj 5 Binary String Matching 【string】

2016-06-11 16:29 190 查看


Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3

描述Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while
the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length
(B) <= 1000. And it is guaranteed that B is always longer than A.
输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


STL string find函数:  ans=str.find(s.ans);[查找的偏移]


ans!=string::npos;[查找结束的意思]


#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
int main()
{
int t;
string str,s;
cin>>t;
while(t--)
{
cin>>s>>str;//C++输入
int ans=0;
int cnt=0;
while((ans=str.find(s,ans))!=string::npos)
{
cnt++;
ans++;
}
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: