您的位置:首页 > 其它

HDU 2899 Strange fuction(三分)

2016-06-09 17:02 344 查看


Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5755    Accepted Submission(s): 4081


Problem Description

Now, here is a fuction:

  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

 

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

 

Sample Input

2
100
200

 

Sample Output

-74.4291
-178.8534

 

Author

Redow

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2199 2289 2298 2141 3400 

代码:

#include<stdio.h>
#include<string.h>
#include<cmath>
using namespace std;
double f(double x,double y)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
double y;
scanf("%lf",&y);
double l=0,r=100;
double lm,rm;
while(r-l>1e-6)
{
lm=(2*l+r)/3;
rm=(l+2*r)/3;
if(f(lm,y)>f(rm,y))
l=lm;
else r=rm;
}
printf("%.4lf\n",f(l,y));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: